aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py44
1 files changed, 17 insertions, 27 deletions
diff --git a/setup.py b/setup.py
index 33a30e3..da6cb20 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -10,35 +10,25 @@ with open('dotfiles/core.py', 'rb') as f:
version = str(ast.literal_eval(_version_re.search(
f.read().decode('utf-8')).group(1)))
-setup(name='dotfiles',
- version=__version__,
- description='Easily manage your dotfiles',
- long_description=open('README.rst').read() + '\n\n' +
- open('LICENSE.rst').read() + '\n\n' +
- open('HISTORY.rst').read(),
- author='Jon Bernard',
- author_email='jbernard@tuxion.com',
- url='https://github.com/jbernard/dotfiles',
- packages=['dotfiles'],
- license='ISC',
- classifiers=(
- 'Development Status :: 4 - Beta',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: ISC License (ISCL)'
- 'Natural Language :: English',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.0',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- ),
+
+setup(
+ name='dotfiles',
+ author='Jon Bernard',
+ author_email='jbernard@tuxion.com',
+ version=version,
+ url='https://github.com/jbernard/dotfiles',
+ packages=['dotfiles'],
+ description='Easily manage your dotfiles',
+ long_description=open('README.rst').read() + '\n\n' +
+ open('LICENSE.rst').read() + '\n\n' +
+ open('HISTORY.rst').read(),
entry_points = '''
[console_scripts]
dotfiles=dotfiles.cli:main
''',
+ classifiers=[
+ 'License :: OSI Approved :: ISC License (ISCL)'
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ ],
)