diff options
author | Jon Bernard <jbernard@jbernard.io> | 2018-08-31 13:02:27 -0400 |
---|---|---|
committer | Jon Bernard <jbernard@jbernard.io> | 2018-08-31 13:02:27 -0400 |
commit | 802de30bf4eabd3f394c02d19e61814a0c718d28 (patch) | |
tree | 5e984b11896838ebb2514702b1a96e4022286964 /setup.py | |
parent | b4870fb1c65c30fbeb4bfa234a3ad43d121475f8 (diff) | |
download | dotfiles-802de30bf4eabd3f394c02d19e61814a0c718d28.tar.gz dotfiles-802de30bf4eabd3f394c02d19e61814a0c718d28.tar.bz2 dotfiles-802de30bf4eabd3f394c02d19e61814a0c718d28.zip |
Rework setup.py, move pytest and flake8 to extras_require
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 16 insertions, 8 deletions
@@ -1,24 +1,32 @@ +import io from setuptools import setup from dotfiles import __version__ +with io.open('README.md', 'rt', encoding='utf8') as f: + readme = f.read() + setup( name='dotfiles', version=__version__, author='Jon Bernard', author_email='jbernard@jbernard.io', - description='Easily manage your dotfiles', url='https://github.com/jbernard/dotfiles', + description='Easily manage your dotfiles', long_description_content_type='text/markdown', - long_description=(open('README.md').read() + '\n\n' + - open('LICENSE.md').read() + '\n\n' + - open('HISTORY.md').read()), + long_description=readme, license='ISC', packages=['dotfiles'], - setup_requires=[ - 'pytest-runner', - 'flake8', - ], + extras_require={ + 'dev': [ + 'pytest', + 'flake8', + ], + }, + # setup_requires=[ + # 'pytest-runner', + # 'flake8', + # ], install_requires=[ 'click', 'py', |