diff options
author | Jon Bernard <jbernard@tuxion.com> | 2016-01-12 17:12:00 -0500 |
---|---|---|
committer | Jon Bernard <jbernard@tuxion.com> | 2016-01-12 17:12:00 -0500 |
commit | a6775c3faead950941517d3d4a3f6b1a84b457df (patch) | |
tree | 5e30a1aec8fd559e70de2c2bab6da0af014809d0 /setup.py | |
parent | 3a8a5714337d54ca239a3add4dd663b9b05ba3af (diff) | |
download | dotfiles-a6775c3faead950941517d3d4a3f6b1a84b457df.tar.gz dotfiles-a6775c3faead950941517d3d4a3f6b1a84b457df.tar.bz2 dotfiles-a6775c3faead950941517d3d4a3f6b1a84b457df.zip |
Integrate pytest and flake8 into setuptools
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 10 insertions, 1 deletions
@@ -12,11 +12,20 @@ setup( open('LICENSE.rst').read() + '\n\n' + open('HISTORY.rst').read()), license='ISC', - py_modules=['dotfiles'], + py_modules=[ + 'dotfiles' + ], + setup_requires=[ + 'pytest-runner', + 'flake8', + ], install_requires=[ 'click', 'py', ], + tests_require=[ + 'pytest' + ], entry_points={ 'console_scripts': [ 'dotfiles=dotfiles:cli', |