diff options
author | Jon Bernard <jbernard@tuxion.com> | 2016-01-15 16:56:31 -0500 |
---|---|---|
committer | Jon Bernard <jbernard@tuxion.com> | 2016-01-15 16:56:31 -0500 |
commit | c1f3adc019452808ea85dbb14661979c5c277eb8 (patch) | |
tree | b475d14699275dcd40e0d7b446147d17591f5141 /setup.py | |
parent | 4ec7ae423fcc957d3d1ee14faea54afbdc406ded (diff) | |
download | dotfiles-c1f3adc019452808ea85dbb14661979c5c277eb8.tar.gz dotfiles-c1f3adc019452808ea85dbb14661979c5c277eb8.tar.bz2 dotfiles-c1f3adc019452808ea85dbb14661979c5c277eb8.zip |
Move implementation and tests back to directories
I think keeping the physical separation is helpful, especially as more
features get added.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 4 insertions, 5 deletions
@@ -1,9 +1,10 @@ from setuptools import setup +from dotfiles import __version__ setup( name='dotfiles', - version='0.7.dev0', + version=__version__, author='Jon Bernard', author_email='jbernard@tuxion.com', description='Easily manage your dotfiles', @@ -12,9 +13,7 @@ setup( open('LICENSE.rst').read() + '\n\n' + open('HISTORY.rst').read()), license='ISC', - py_modules=[ - 'dotfiles' - ], + packages=['dotfiles'], setup_requires=[ 'pytest-runner', 'flake8', @@ -28,7 +27,7 @@ setup( ], entry_points={ 'console_scripts': [ - 'dotfiles=dotfiles:cli', + 'dotfiles=dotfiles.dotfiles:cli', ], }, classifiers=[ |