aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py43
1 files changed, 19 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index 90fd1ea..522aa39 100644
--- a/setup.py
+++ b/setup.py
@@ -1,45 +1,40 @@
-from io import open
-from os import path
from setuptools import setup, find_packages
from dotfiles import __version__
-here = path.abspath(path.dirname(__file__))
-
-with open(path.join(here, 'README.md'), encoding='utf8') as f:
- long_description = f.read()
-
-test_requirements = [
- 'pytest',
- 'pytest-pep8',
- 'pytest-flakes',
-]
-
setup(
name='dotfiles',
version=__version__,
description='Easily manage your dotfiles',
- long_description=long_description,
+ long_description=open('README.md', encoding='utf-8').read(),
long_description_content_type='text/markdown',
- url='https://github.com/jbernard/dotfiles',
author='Jon Bernard',
author_email='jbernard@jbernard.io',
+ license='ISC',
+ url='https://github.com/jbernard/dotfiles',
+ packages=find_packages(),
+ tests_require=[
+ 'pytest',
+ 'pytest-flake8',
+ ],
+ setup_requires=['pytest-runner'],
+ entry_points={
+ 'console_scripts': [
+ 'dotfiles=dotfiles.cli:cli',
+ ],
+ },
+ install_requires=['click'],
classifiers=[
'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
'License :: OSI Approved :: ISC License (ISCL)'
+ 'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Utilities',
],
- packages=find_packages(),
- install_requires=['click'],
- setup_requires=['pytest-runner'],
- tests_require=test_requirements,
- entry_points={
- 'console_scripts': [
- 'dotfiles=dotfiles.cli:cli',
- ],
- },
project_urls={
'Bug Reports': 'https://github.com/jbernard/dotfiles/issues',
'Source': 'https://github.com/jbernard/dotfiles',