diff options
author | Jon Bernard <jbernard@jbernard.io> | 2018-10-02 21:19:47 -0400 |
---|---|---|
committer | Jon Bernard <jbernard@jbernard.io> | 2019-03-05 10:16:06 -0500 |
commit | ac121c58aee4a606626bd387d782151eb58d6a67 (patch) | |
tree | 2462233963d11d62fe1f3e8af65959128f543913 /setup.py | |
parent | 2c14d3073c073957e36533d56dce59a1b1abc0b4 (diff) | |
download | dotfiles-ac121c58aee4a606626bd387d782151eb58d6a67.tar.gz dotfiles-ac121c58aee4a606626bd387d782151eb58d6a67.tar.bz2 dotfiles-ac121c58aee4a606626bd387d782151eb58d6a67.zip |
Start transition from py.path to pathlib
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 17 |
1 files changed, 3 insertions, 14 deletions
@@ -8,11 +8,6 @@ here = path.abspath(path.dirname(__file__)) with open(path.join(here, 'README.md'), encoding='utf8') as f: long_description = f.read() -requirements = [ - 'click', - 'py', -] - test_requirements = [ 'pytest', 'pytest-pep8', @@ -37,11 +32,9 @@ setup( 'Programming Language :: Python :: 3.6', ], packages=find_packages(), - install_requires=requirements, - extras_require={ - 'dev': ['check-manifest'], - 'test': test_requirements, - }, + install_requires=['click'], + setup_requires=['pytest-runner'], + tests_require=test_requirements, entry_points={ 'console_scripts': [ 'dotfiles=dotfiles.cli:cli', @@ -51,8 +44,4 @@ setup( 'Bug Reports': 'https://github.com/jbernard/dotfiles/issues', 'Source': 'https://github.com/jbernard/dotfiles', }, - - # temporary - setup_requires=['pytest-runner'], - tests_require=test_requirements, ) |