aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 3 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index d12fd4c..90fd1ea 100644
--- a/setup.py
+++ b/setup.py
@@ -8,11 +8,6 @@ here = path.abspath(path.dirname(__file__))
with open(path.join(here, 'README.md'), encoding='utf8') as f:
long_description = f.read()
-requirements = [
- 'click',
- 'py',
-]
-
test_requirements = [
'pytest',
'pytest-pep8',
@@ -37,11 +32,9 @@ setup(
'Programming Language :: Python :: 3.6',
],
packages=find_packages(),
- install_requires=requirements,
- extras_require={
- 'dev': ['check-manifest'],
- 'test': test_requirements,
- },
+ install_requires=['click'],
+ setup_requires=['pytest-runner'],
+ tests_require=test_requirements,
entry_points={
'console_scripts': [
'dotfiles=dotfiles.cli:cli',
@@ -51,8 +44,4 @@ setup(
'Bug Reports': 'https://github.com/jbernard/dotfiles/issues',
'Source': 'https://github.com/jbernard/dotfiles',
},
-
- # temporary
- setup_requires=['pytest-runner'],
- tests_require=test_requirements,
)