diff options
author | Jon Bernard <jbernard@tuxion.com> | 2014-07-07 14:08:33 -0400 |
---|---|---|
committer | Jon Bernard <jbernard@tuxion.com> | 2014-07-07 14:08:33 -0400 |
commit | e377456dc12a05d685b31cab0b6d62f2c0864f5a (patch) | |
tree | ed7eb565519b9e6b70be2c606112bd5fce78e635 /setup.py | |
parent | d42db02de0519fade43406cf887cc16d37a1032b (diff) | |
download | dotfiles-e377456dc12a05d685b31cab0b6d62f2c0864f5a.tar.gz dotfiles-e377456dc12a05d685b31cab0b6d62f2c0864f5a.tar.bz2 dotfiles-e377456dc12a05d685b31cab0b6d62f2c0864f5a.zip |
Use entry point for bin stub
The script in bin/ remains for running directly from the source
directory.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -37,5 +37,8 @@ setup(name='dotfiles', 'Programming Language :: Python :: 3.1', 'Programming Language :: Python :: 3.2', ), - scripts=['bin/dotfiles'], + entry_points = ''' + [console_scripts] + dotfiles=dotfiles.cli:main + ''', ) |